About 2 weeks ago my pivot tables started dis...

(Mark Cobb) #1

About 2 weeks ago my pivot tables started displaying a blank sheet rather than weekly and monthly totals from my Jobs. Did something change with AppSheet or Google Sheets about 2 weeks ago? Fix? Please see the screenshots.

(Tony Fader) #2

@Mark_Cobb It appears that Google may have changed something with the way that pivot tables are generated, which is causing some problems with AppSheet. See the solution described in this thread: plus.google.com - Google Sheets bug — “internal server error” A few users have reported that… Google Sheets bug — “internal server error” A few users have reported that… plus.google.com

(Mark Cobb) #3

@tony I saw that initially but dismissed it because the pivot table issue started about 2 weeks ago. Nevertheless I will try re-creating the pivot tables and report back.

(Mark Cobb) #4

@tony I finally got around to re-creating a pivot table. It’s still showing a blank table when selecting my PT menu item. However I learned a few things that may help figure out what the problem is…

When initially adding the new pivot table to Data > Tables I would get “Could not read worksheet because the table is empty”. Once I added header columns above the pivot table, all errors went away - however it still shows blank in my app. You’ll notice in the screenshot that the PT uses bold and italics formatting for the header rows (Mo & Tot), however the formatting cannot be removed. As mentioned in the other thread, I wonder if the PT text formatting is causing my problem?

AppName is CTJobs1-109217 if you want/can look at it.

(Tony Fader) #5

@Mark_Cobb It looks like you’ve got two header rows. Can you use just one and see if that helps?

(Mark Cobb) #6

@tony The other PT sheets have one or no header - and they’re blank as well.