Action "Data: add a new row to another table using values from this row" selects all rows from the source table

Hi folks

I have source data in two tables / tabs within a Google Sheet document, and I’m trying to use AppSheet to help combine these similar-but-slightly-different data sets into a single consistently-structured data set. The idea is that I surface the data in AppSheet, then use the “Data: add a new row to another table using values from this row” Action to selectively import specific rows into the target table. I have defined a specific “Copy Record” Action for each data source (screen snips to follow in subsequent posts):

I’ve assigned the action to the UX, but for any of the columns it’s copying based on existing data, it’s selecting values from all the rows and dumping them into the single new row (screen-shots to follow).

I’ve already checked the data types between the source and target tables are aligned. I also tried encapsulating the data being transferred in withing the TEXT() function, also without success.

Do I need to define a filter under Action > Behaviour? (It’s currently blank…)

I can’t help but think I’m stuck on a ‘trap for new players’ and that I’ve missed something simple… can anyone help me understand what am I doing wrong?!?

Thanks!

Screen snip of Action #1:

Screen snip of Action #2:

Data from one of the source tables:

This is clearly showing two quite discrete records, before the Copy action.

Data from the target table:

Running the Copy action for each of the source rows has created two distinct records (unique keys) containing the same concatenated source data.

An expression of the form, table-name[column-name] (e.g., Form Responses[Child's Gender]) produces a list consisting of all values from the column named in the table named. It appears you instead want the column value for only the current row. For that, just omit the table name (e.g., [Child's Gender] instead of Form Responses[Child's Gender]).

I also suspect you don’t need the TEXT() function where it appears in your screenshots. It may actually cause problems later unless you’re using it for its particular behavior.

Hi Steve

Thanks for the tip; indeed a “trap for new players” as I suspected! Curse my trying to be too specific.

Your suggested fix has worked, as demonstrated below:

Thanks again!

1 Like