Action not appearing in the "Action To Run" dropdown menu when creating a workflow/Bot

Looking for some help here.

I have created an action as follows.

I have then created a Bot that I want to execute that action but it doesn’t appear in the “Action To Run” drop down menu found under: ‘Run a task’, ‘Change Data’.

All my other actions I have created for this table appear but I have tried everything and I can’t get this one to show up. Am I missing something?

actions cannot call workflows.

1 Like

I was not trying to execute a workflow with an action. I fixed my phrasing a bit. Hopefully that is more clear.

What is the action that you are trying to get it to execute? Specifically the type of action.

There is an image of the action in the original post. It is ‘Data: execute an action on a set of rows’ with the referenced action as ‘Delete’. Any help would be appreciated.

Thanks!

oh duh…
that’s odd. I have an execute action on a set of rows used in one of my workflows. Maybe try this in the automation tab as a bot?

Tried running as a Bot as well. Does not have that action listed in the dropdown menu.

If anyone else runs into this while making a bot, I discovered the solution. I’m pretty sure that this is a bug. If you use the ‘settings’ panel on the right hand of the screen while creating a bot, when you get to the section where you create a task not all of your available actions will show in the drop down menu under ‘Action To Run’. If navigate to the ‘Tasks’ panel on the top of the page, create your task there first, then create the bot everything shows up as it should.

2 Likes

Recategorized as #appsheet-automation.