Action not displaying overlay

behavior
(Curtis Pazdar) #1

Hello Appsheet,

In my app I have tried to disable the add action and replacing it with a LINKTOFORM() action but I cannot get it to display overlay like the system generated Add action will see the pictures below for the difference from the system generated add to my LINKTOFORM() action.

image - system generated add

image

(Levent Kulacoglu) #2

@Curtis_Pazdar
Deeplink actions appear as overlay only in Detail View

(Steve Coile) #3

You cannot replace the system-provided Add action displayed in table views.

What are you trying to accomplish?

(Curtis Pazdar) #4

Okay, well that answers one question because I was trying to replace the system generated add. I am trying to add rows to that table but I am trying to make the entry form as few fields as possible. So I have fields for that data that are set to “Show” because I need to see them when they select the detail view of a row but I do not want them to appear on my add row entry form. To try and get around that I created a form from a slice from the same data and tried replacing the system generated add with the LINKTOFORM() posted above (that does not work). You might say if the fields arent required why does it really matter if they still appear on the form, I just want it to look simple enough where inexperienced workers using this app will not avoid filling out the form because they do not have all the information available at that current moment

(Levent Kulacoglu) #5

@Curtis_Pazdar
I may advise using below expression in your Show_if expression:

CONTEXT("ViewType")="detail"

those fields will not appear in the Form View.

(Curtis Pazdar) #6

That sounds like that will work to me. Thank you Levent I haven’t used the context function much so far so that wasn’t an immediate thought for me.

(Curtis Pazdar) #7

Alright Levent/Appsheet I have one more question for you regarding this system generated add. I have this table view (same one as above) grouped by project. Previously when I pressed the system generated add overlay action it would populate the projects field with what ever project I was currently in. Say I selected “Laradon Homes” and was looking at that grouped table view if I pressed the add action the project field would be pre-populated with “Laradon Homes”. It no longer does this. I am curious as to what setting have to applied to that column of data to make sure it pre populate like it did before, it honestly was unexpected but a nice surprise the first time I noticed it did this.

1 Like
(Levent Kulacoglu) #8

@Curtis_Pazdar
One of our valuable member @Lynn was also asking for the same issue here > Autofill based on group user is viewing
I haven’t tested such behaviour, but I will. Until than I would like to chime in @tony for further investigation.

1 Like
(Curtis Pazdar) #9

This has been working again on one of my forms @Lynn @LeventK I do not know if anything is changed but I’m glad to see it again. It is auto-filling both the “Assigned To” name and the “Issue Date” with today’s date.

1 Like
#10

Hi @Curtis_Pazdar @LeventK Thanks for the update. I Just checked and mine are working again also. Saves time and mistakes. So pleased to see it back.