Actions won't execute - Urgent Issue

I suddenly have an issue where some actions have ceased functioning without an apparent cause. For example, when I click the delete button nothing appears to happen, no syncs queue up. If I click the button rapidly several times, the row will appear to be deleted but reappears after moving to another view.

I’m seeing the same behavior when creating a new row, the new row exists for a brief moment before disappearing. None of this activity is reflected in the audit history and I’m not receiving an error. Form views that have actions tied to them also refuse to execute. The form will appear not to save on the first click, but on the 2nd click it says “There is already a row with the key 1234123” and keeps you on the form view.

A simple action that updates the value of a single column will update if you hit the action several times fast, then roll back when navigating to a different view.

I’m at a loss to troubleshoot this further, it appears that some behavior has changed behind the scenes and broken something that I am unable to see or diagnose. I’ve tried removing security filters, rolling back the app to a known good version, duplicating the app, creating new/replacement tables, nothing appears to fix this and I cannot find a root cause. Every user appears to be affected on every device. I’ve also tried re-authorizing Appsheet to access the database with a different user with no change.

This has brought our timekeeping app to an abrupt halt and is a huge problem. I’ve already emailed support and am waiting to hear back. Has anyone else experienced anything similar? Any ideas on what might be going on here?

@praveen @Aleksi @Phil

Conor, I’m looking into it and have sent some responses on the support thread. We have not heard any issues from any other customer. So far, it seems like this is something unique to your app.

The symptoms you describe are at least very similar to a data source that isn’t writable: the changes from the app exist in the app until a sync, then they disappear because the data source won’t store them.

Can you connect to and make changes to the database with a SQL client using the same credentials AppSheet uses?

Does your database itself manage access by client IP address? If so, is that list current?

Is your firewall access list for AppSheet access current?

Looks like this was a bug in our app/device-side code, but it might be caused by an invalid expression that wasn’t being caught as an error when the app was being edited/saved. We’re still investigating but have deployed a workaround to unblock Conor

5 Likes

I’ve confirmed that the issue is fixed on Chrome, iOS, and Android. We greatly appreciate the help Praveen. Following the swift fix last night, one of our nightshift users was able to use the app like they normally would have without any additional intervention on my part. Please let us know what comes from the investigation!

2 Likes