Add a row to a table

Ok, I’m banging my head against a wall here. I’m trying to install an action into my app where it copies data from one table and inserts it as a row in another table. I’m trying to use the option in actions “add a new row to another table using values from this row”
I believe I set the columns correctly, but as soon as I hit the button I get this error message
Error running action, no result expression for column:

I’ve tried to connecting it to different columns to see if I’m doing something wrong, or even just typing text in, but I still get the same error each time. What am I doing wrong here?

Thanks in advance

Hi @School_Bus
Could you please show a screen shot of your action in the editor thanks.

1 Like

here is what it looks like

What is the expression you are using?

1 Like

It’s just a reference to the column from the other table

How do you use that reference? It seems that your resulting expression is not correct.
[Route Number][AM Driver....]
If this is a de-ref expression, the format shall be:
[Route Number].[AM Driver....]
Notice the ‘dot’ in between the column references

1 Like

I was able to go back and find that I had some required columns which I didn’t have references for that stopped me from adding a row. Then I tried again to find out that I can complete the action if I only add columns that have computer generated information in the related column. For example in the date of my reference column I use an initial value of today(), but any of the manually inputted data seems to cause an error. Say I have a column with “Dave” in it, it causes a problem and brings up that same error. The screen shot I provided earlier had an issue that I fixed. Attached is a new screen shot.
The Route ID reference column generates a UniqueID(), but the Driver EID AM reference column is manually inputted in the reference column.

Ok, dumb resolution. I just needed to hit the save button, and the action seemed to work after that.

1 Like

Excellent!