Add New Record, Select Record and then Deepli...

(StudentHomes Plymouth) #1

Add New Record, Select Record and then Deeplink to Filtered View?

Can anyone help me out? I am trying to add a new record to “TableA” and then select a view based on “TableB” that matches a criteria set in “TableA”. In summary I want to achieve the following:-

  1. Add new record to “TableA” with ID value of “xxx” 2. Select a view based on “TableB” that only contains records with ID value of “xxx”

I do not want to set a filter on a slice and so thought the approach noted below would work, but it simply ends up displaying all the records from “Table B” and not just the ones that fulfill the filtered view criteria.

  1. Have simple form to enter data for “Table A” - 3 columns comprising TableBid (unique value), ID (text), Filter (Y/N) 2. Action on form saved called “GotoFilteredView”

Action GotoFilteredView comprises:-

Action name: GotoFilteredView For record in table: Table B If this condition is true: [_THISROW].[Filter] Do this: App: go to another view within this app Target:

LINKTOFILTEREDVIEW(“TableViewB”, IN(TableB[ID],TableA[ID]))

Validation message states “Navigate to ‘TableViewB’ …and show rows where this condition is true: ( …(TABLEB[ID]) is one of the values in the list (TABLEA[ID]))”

Problem may be to do with using the filter condition “TRUE” in TableB but I don’t know how to select the data for just the new row I have added to filter any other way.

I have spent hours trying to get this to work and at face value cannot see why it doesn’t - can anyone HELP me out?

(Aleksi Alkio) #2

If I understood your request correctly, you could try it like this… LINKTOFILTEREDVIEW(“TableViewB”,[ID]=[_THISROW].[Filter])

(StudentHomes Plymouth) #3

Thanks for your prompt response, sadly that doesn’t work either. I have confirm action on and it says it is running the action, but it ends with blank screen not displaying any records. Also when I run “Test” in expression builder it displays all records and not just the filtered one. Also the formula is not comparing the correct columns so I have just tried amending and ignoring filter (Y/N) column for the moment

LINKTOFILTEREDVIEW(“TableViewB”,TableB[ID]=[_THISROW].TableA[ID])

However that then errors stating

Cannot compare List with Text in (TABLEB[ID] = [_THISROW].TableA[ID]).

So I tried IN expression and still returns all records. Just cannot understand why this will not work.

(StudentHomes Plymouth) #4

Finally resolved it!

For the benefit of anyone who may experience the problem I dropped the idea of a filter column and then changed the expression to

LINKTOFILTEREDVIEW("“TableViewB”", [_THISROW].[ID] = [ID])

Note: if you include the table name in front of the second [ID] I found it (a) doesn’t need it and (b) doesn’t work.

Hopefully this may save some of you the hours of fun that I have had trying to get it to work.

(Aleksi Alkio) #5

Wuhuu

(Arabian Corner) #6

@StudentHomes_Plymout

Thanks for this, I almost gave up on idea after attempting for

over 1 week. This is really a great feature…

(StudentHomes Plymouth) #7

Glad it’s of help!