Adjust PDF Margins?

I am currently using a word template and have everything lined up perfectly. When the workflow trigger the PDF creation I notice that the final pdf has really wide margins, mashing my data into strange positions. Is there a way to set wider margins for the PDFs being created? Changing it in the template doesnt seem to have any effect.

Can you provide screenshots of the template and created PDF, so we could compare the margins?

Top is the template in Word

Below is appsheet PDF

Thanks in advance,

Jethro

@Jethro
I may advise creating all the template items inside a 1 row 1 column table in the gDoc and make its borders 0pt thick and white color. Then the PDF parser will possibly respect the borders of the table :slight_smile:

@LeventK @RezaRaoofi I actually did use Gdoc with a single column single row table but it gave far worse results. Items were moving all around the page and it was as if nothing translated 1:1 from Google doc to PDF. Results were a bit better with WORD with margins being my only major issue. Any additional advise on where to look would really help as I am completely stuck on this.

Well, from what I can see in the above picture your template document currently has left and right margins; have you tried going to page setup and change them to zero?

1 Like

Hi @Reza
Good idea but as per my experience, AppSheet’s PDF parser does not obey to the gDoc page settings unfortunately. But of course, I’m not aware if anything updated till now. May be we can ask this to @Phil

I just quickly tested it on a Google Doc template; set default 2.54 cm left margin to zero and could reduce the PDF margin to this:

1 Like

@Reza @LeventK

First of all thanks for your input which pointed me in the right direction. LeventK I reverted back to Google Docs and as you suggested I created single a row and column table as I had previously done. Seeing as Reza is right; I was able to align the table using the margin properties from GDoc, it got me thinking that maybe my issue was not only the margins.

I went back and did as Reza suggested and managed to widen the margins. My data now seemed to fit as required however the data in the table rows were not aligning once I parsed the template through to PDF.

For the benefit of others:

  1. Yes, the PDF parser margins can be adjusted by tweaking the GDOC margin properties

  2. Make sure all entries in each cell does not have trailing spaces!!! You cannot see them in the template and everything looks nicely aligned, however the parser seems to process trailing spaces in such a way that it will : mess up alignment (eg. some entries wont center) and cell padding will differ from row to row. Once you remove trailing spaces everything looks good and works well.

Thanks for the help! SOLVED

3 Likes

@Jethro
Glad to hear that you have solved the problem. Also, with the table properties of gDoc, it’s a good idea to play with cell padding property as well :slight_smile:

1 Like