Allow Appsheet Access to MySQL on Amazon VPC?...

(Karl Rolfe) #1

Allow Appsheet Access to MySQL on Amazon VPC?

Hi There. The MySQL on my local NAS died so I’m desperately trying to setup an instance in Amazon’s RDS. I’ve got the database set up there but run into a roadblock allowing AppSheet access to it. I put in my user credentials (I’ve tested they all work with MySQL workbench) but AppSheet can’t connect.

OK so I googled and found an instruction from AppSheet on how to connect to an Amazon RDS “Using MySQL on Amazon RDS” but it describes setting up a Security Group which seems to be a legacy system no longer supported. It seems to have been dropped and new users now use VPCs. I can’t find any instructions on how to allow access through the VPC. I have searched through here and can’t seem to find anything either. Can someone give guidance please.

(Karl Rolfe) #2
(Karl Rolfe) #3

OK I got it working. Not sure the exact step which fixed it but it works now. If I can work out which step fixed it I’ll post here.

(Karl Rolfe) #4

For completeness I’ll post here what I did: In the Amazon Web Services console select RDS service (under Database).

(Karl Rolfe) #5

Select Instances on the left panel

(Karl Rolfe) #6

Select your instance

(Karl Rolfe) #7

Scroll down to the Details section and under the heading “Security groups” click on the link with “wizard” mid string.

(Karl Rolfe) #8

On the resulting window select the security group in the top list and “Inbound” tab in the bottom section then hit the Edit button to add an entry. Done!