Always an error and I do not know of what to do

I did the app to help my brother in his business, and he is in a different country I’m Middle East.

The app work perfectly at first, but later any time he tried to enter data, he get message said

  • " Unable to add/delete row in table >> my sheet name that he tried to enter the data !!<< google.
    *App, Request. RequestError
    *The caller does not have permeation [403]
    *Errors message [The caller does not have permeation]
    *Location Reason [forbidden] Domain [global]

I’m really confused of what to do pleaseeeee help

Please contact support@appsheet.com directly for help with this.

1 Like

After building the app, have you transferred the ownership of the app? Under whose account the app is? Can you elaborate?

1 Like

No I have not transferred the ownership because my brother will not be able to understand anything. also, it is under me account and my email. what I did!!, I added his email to use the app as user. it works perfectly in the dashboard with me. when my brother downloaded, it works perfectly at first… after while he try to enter another data, it says [sync to co…]
and on the update icon at the top right, it seems need to be updated, when click on it, he got that message and nothing happened at all. please see the picture

Can you please check his access mode to the tables. Are they set as app user or app creator from DATA > TABLE > SECURITY. Additionally, what is your AppSheet plan type?

2 Likes

Asmenmtioned by @LeventK:

2 Likes

it is as a user. what it should be for him as user or creator?

it is as user and what is it should be ?? … honestly I’m confused of your question regard to the plan of the AppSheet but it is personal and to handle my brother expenses if this was your question.

It has to do with the way appsheet accesses your data… Switch it to “as app creator”

1 Like

It should be set as app creator as your brother is merely the user of your app so the back-end is under your account and his app needs to access it. app user is used when you have data partitioning (which needs a corporate plan as well). Switch it to app creator and the problem will be solved.

3 Likes