App Editor nor App Loads

I was working on building some reports and then right in the middle of the work the editor just stops responding like I lost my wifi connection. I didn’t think anything of it, just closed my laptop and finished my breakfast.

Just got home and the app editor for my app still won’t load and now the app won’t load either. If I could get into the editor I could roll back the version to figure out what I did to cause this but that’s not an option.

I don’t know what to do, my entire business runs on this platform and it’s going to be a mess tomorrow when I open back up and have to hack everything through the spreadsheet.

Any ideas?

Updating this in case somebody else runs into the same problem.

I haven’t fixed it yet, but if you open a “private” or “incognito” tab and log in it seems to work just fine. Otherwise you have to load the editor from another browser or device.

I’m still working on how to fix the problem in my regular desktop browser: Safari. I will update again if I figure it out.

Screenshot showing the problem?

Are any error messages displayed? If so, post screenshots, please.

What happened when you tried restarting or reloading the browser? Did you try clearing the cache?

Do you have any browser extensions or add-ons installed?

Are you using a VPN?