App not displaying images

Hello AppSheet community,

I have got an issue with my app displaying images properly. To be exact, wherever there is supposed to be an image - be it an icon or an uploaded photo - there is an exclamation mark instead. I’ve read some previous articles on why pictures do not show up and tried the recommended steps but so far without any luck.

  • offline storage of content is off
  • column is image and naming is relative to app sheet spreadsheet
  • security setting on gdrive is anyone with a link can see the pictures
  • when I tried uploading an image through the app, it showed for about a minute and then disappeared

Thank you so much for your help,
Kryštof

Are the images visible in the Google Drive folder?

1 Like

Thank you for the reply,

yes, they are both visible and accesible.

Right click on the cell in Google Sheets and choose “Show Edit History” to see if something is changing the filename after it has been uploaded

1 Like

So in the edit history there were actually two versions uploaded at the same time. After downloading both of them, I was unable to open the original one because of “unsupported format or possibly damaged file”. But the current version is working… I expected it to be the other way around if this was the case?

image

So it sounds like you’ve got a formula or workflow thats changing the image column as your adding it. Look into this.

1 Like

Even though most of the images weren’t uploaded through the app? For example icons in the menu…
Also the images used to appear normally about a month ago, if that’s relevant.

Does it work on a different device?

1 Like

Unfortunately, it does not.