App not syncing on every device

Hi all

I just met an issue with my users : they usually use an app launcher to access their apps.
Yesterday I changed a data table to add 3 more columns (from 13 to 16), and everything seemed to work fine on my tests.

This morning, one of my app accounts worked perfectly well, as planned, and the other one cannot sync anything, which is surprising because they use the same app launcher, with the same shortcut, and the same iPhone device.

I switched the app to recovery mode in order to release datas from this smartphone, but even in that configuration the app does not want to sync.

I tried to regenerate again the data table, to reinstall the shortcuts, no changes.

Many thanks for your help

Aurelien

Have you checked which amount is correct?

the correct one is 16 : column A to P.
the previous one, now incorrect, was 13 : A to M

this might be due to a workflow : table “Mouvements” has 9 columns.
and from then, a row is added to table “Line Item”.

What do you think ?

Hi @Aleksi,

any idea of where I can look into ? Do you need more informations ?

I had news from my user : among 7 whitelist users, 2 still cannot sync their app (but they can open it without any errror message)
In the meantime, I realized I forgot to deploy the app, which I did then, but that did not impact the behaviour of the blocked account.

We did not try to uninstall app on their devices, because we are afraid of any data loss.

I look forward to hearing you

Aurelien

Hi Aurelien,

Do you know what devices they are on? Can you try to manually sync the app with the refresh button?

Billy

Hi @Billy_Sheng

Thanks for your message.

  • Devices are iPhone
  • app opens normally, but sync fails. Here is the message one of my users get at trying to sync (he tried this morning - Swiss timezone) :

I just noticed something : on the error message, you can read the app version : 1.000020.
But, on my web interface, I get this :


Which displays : 1.000056

I cannot explain how this is possible, are these numbers about the same subject ?

Thanks

@dev Your user has an old version of the App. Please try following:

  • delete the 3 columns you’ve added since the old version (it says: the actual table has 16 columns, but in the old App version it has only 13)
  • tell the user to do a sync
  • restore the 3 columns in your sheet
  • tell the user to sync again

Under Behavior --> Offline/Sync you should enable “Sync on start”. This will ensure that your users are working with the latest version of the app.

1 Like

Hi @Fabian

Wonderful, you got it !

Nonetheless, at looking on the “Sync on start” option, it was yet checked, which is quite strange.

I guess this comes from a previous situation, because at first, this option was not checked when my user started using the app (even if I don’t remember when exactly I checked it).
Maybe the app kept that in memory ?

Anyway : problem solved, thanks again !

Aurelien

1 Like

Awesome Fabian! Thanks for helping

1 Like