App not updating its data table

My data table updates every 12 hours in a google sheet but my app isn’t catching the updates.

I’ve tried re-syncing and turning “off” the delayed sync but still can’t see the updated data. Funny thing is it worked in my prototype but has stopped working since I signed up for pro (I also did some other changes so this may be unrelated).

Any ideas why my app is unable to pull the updated google sheet data?

Is the table you are working on is possibly set to “Read-only” ?

2 Likes

You nailed it my friend! I was afraid turning on “updates” would allow users to write to my back end table (write “updates”) but now it appears that’s in reference to the app pulling table updates. Thanks!

To protect the table data being edited by user, hide system generated “Edit” icon to stay the table “read only” as you want.
But when we set the table read-only, the data should be cached to Appsheet server and your app will read that instead of the live backend data. So you see the old data when you synced, which was saved to Appsheet server.

Hope this makes sense with you.

2 Likes

Very much so. Thanks for explaining.

1 Like