App on Browser not showing all data

Hi Guys,

I have users reporting that they are not finding customers in the app. When they call for support and provide the customer number and the search is performed the customers is found. The search are done in the same app but in different computers. The users run AppSheet on a FireFox browser and I am using Chrome.

The data source is MySql

Asked other users to look for the missing customers on different browsers besides FireFox and they report the same error, customer not showing.

The search option is check on the search column, the tables have security filters based on date and customer type.

Search options

Screen Shot 2020-10-15 at 5.29.12 PM

Security Filters
Screen Shot 2020-10-15 at 5.29.02 PM

Screen Shot 2020-10-15 at 5.29.12 PM

Eerie this occurs on the same day a similar issue affects many users:

1 Like

Is this still a problem?

@hodgson.doug this was happening for us before yesterday.

@Steve I have put some checks in place to monitor if the issue is occurring. Created a Chart with total count of rows of the main table. Then created a view in MySQL that has the same filter as the main table. Imported this view to the app and created a chart based on it. The user can check if both graphs have the same quantity of records.

Will run checks with different user and browser todays.

1 Like

My issue was exacerbated by the uncaught bug in yesterday’s update, but resolved and turned out to be one of improper permissions by the user. Have you confirmed that all users have permission using their Gmail account to both your AppSheet AND your MySQL database file?

Wait, I recall seeing that filters on main tables can hide rows for users. Another task for you to double check. :sweat_smile: Hopefully you find the issue, so please share if/when you do, thanks.