AppSheet Formula not Updating in App or Google Sheet

Good morning AppSheet Community,

I am encountering a problem with my AppSheet Formula. This formula adds the sums of two columns from another table. AppSheet says that the formula works, however, the data is not updating in the app or the google sheet. I have tried to make the formula an initial value, but that did not work either.

Can anyone help?
Thanks

Formula in AppSheet:

“View Data” in Appsheet:

Google Sheet:

The Initial value expression is only applied when a new row is added to the table using the app. I don’t see a data row in your spreadsheet. Have you tried adding a new row using the app?

2 Likes

No, I have not. I am am searching about ways to add a row to a table, but they include using actions which I am not familiar with.

This table uses data from other tables and not user input, so is that the reason that it is not updating?

Absolutely.

Keep in mind, although AppSheet can use spreadsheets to store data, AppSheet is not a spreadsheet, and does not inherently work like one.

Thank you so much for your help @Steve , however, I am very confused. I built my app using this sample app as a reference:

https://www.appsheet.com/samples/Built-from-your-app-spec-?appGuidString=8a000953-a917-47c8-9bf0-32146d351366

The table that I was talking about is for a chart, very similar to the chart view in that sample app. I used the same formula, but for some reason nothing is happening. No data is being input into the columns… I’m not sure where I have gone wrong.

What I mean to say is the table in the sample app operates only with data from other tables and does not require user input from other tables. The table in my app is the same, however, it is not working.

Have you tried using a virtual column for the formula instead of a real column?

Yes, that has not worked either.

add a single record to your table

I’m afraid I am not familiar with how implement this into my app. The columns Recycling Chart Table in my app combines values from the Plastic, Glass, Paper, and Aluminum tables in my app.
Nothing, however, is working. Even the email column, which has an initial value formula of USEREMAIL(), is blank. I feel as if I am missing a step or something like that.

The strange thing is, when I click “View Data”, everything is blank, when I go to the google sheet, everything is blank, and when I choose the Chart view everything is blank. When I choose the form view, however, there my data is! I’m very confused.


Essentially, the app sees the data, but it is not storing the data in the table. How do I make it store the data?

image

Looks like you need to enable Adds for this table:

2 Likes

Wow, that did the trick! Thank you so much @Marc_Dillon !!

1 Like