AppSheet Statement on Log4j Vulnerability (CVE-2021-44228)

Below is AppSheet’s initial statement regarding the Log4j Vulnerability (CVE-2021-44228).

The AppSheet core platform runs on non-JVM (non-Java) based runtimes. At this time, we have identified no impact to core AppSheet functionality. Additionally, we have patched one Java-based auxiliary service in our platform. We will continue to monitor for affected services and patch or remediate as required.

If you have any questions or require assistance, please contact AppSheet Support. For more information, please refer to Google Cloud’s Security Advisory on the Log4j 2 Vulnerability.

9 Likes

Hi @Mike_Procopio

Thank you for your response despite the weekend.:pray:
It is a great relief for AppCreator that the AppSheet team is aware of this issue and is addressing it.

6 Likes