At What Stage Apps can't be copied?

Dear all,

I’m not really looking for a specific answer here but maybe getting some discussion going. When you make apps with many tables, you reach a point when you want to copy the app and the tables too, the system returns error.

At What Stage Apps can’t be copied?
Is there a way around to copying the app and the tables?
Is size the only issue?
What is the greatest obstacle to copying?
It may be internet speed too?
Maybe after #NewFeature google drive integrates inside appsheet itself, this limitation on copy-abled app will be solved?

Cheers!
-j- erry

I create a copy of my app as a backup at least once per week. I haven’t hit any limits.

  • 28 Tables
  • 311 Columns
  • 82 Slices
  • 216 Views
  • 8 Format Rules
  • 117 Actions
  • 14 Workflow Rules

Your app is quite big too! There is hope then. Let me try to get the error I got tomorrow and then post it here. Its not my lucky day with the computer today.

1 Like

Hi there,

Could you please share what exact error you met when you copying the app? My assumption would be timeout error if your app data is pretty large. If that’s the case, usually it’s not how complicated your app is but caused by too large amount of data stored in gDrive/OneDrive/etc. We do not set a hard size constraint, but we do set a timeout so if the data is too large and not copied in a given time, it may fail. It’s not related to your internet speed too much. Our current suggestion would be trying to copy app without data. However, this would lead to the new copied app uses original data source, if you want it to use new tables, you may have to manually copy the tables and modify the app to make it points to new tables.

Hi Yizhou,

Yes it should be related to time-out. At one point, I got lucky and managed to copy the app. If I have any finding as to why I got lucky, I will share here. I have been doing pointing to new tables before as I was just doing for my company but now since I am doing Appsheet apps full time for other companies (for the time being), I need to replicate the same app with new similar table (i.e blank).

But “lucky” is not a good way to go about. Do you think when google drive embed inside the appsheet interface, this problem will get solved? Maybe its because I’m in Singapore and not in US that there is a faster time-out.

Here is part of the error screenshot:

Hi appsheet and Yizhou,

My finding came out quicker than expected. It turned out that it was not luck. Even though there was message: “Error Cloning App”, appsheet is still doing the copying in the background. A Check few hours later and the app is cloned with the new tables!

2 Likes

Thanks for the update and happy to know it finally works out. As for your questions, I don’t think it would save much time because of appsheet if now part of google, since copying files from one place in gDrive to another place still take time. As for your case, I think what you need is to copy the same app with tables in same schema but without data. We may later provide option of this, so you will have three options(copy everything, copy app only and copy app with table but no data), will keep update once we prioritize this feature.

4 Likes

This would be very useful when copying apps with a large amount of images.

I’ve ran into the same problem as @Jerry_Lan and received a timeout error when copying larger apps, but if you wait long enough it still finishes in the background. As a workaround, I will temporarily delete data from the source app before copying, and restore the data after.

2 Likes