Automation Error

Why am I seeing this error when I use lookup() inside a workflow template ?

Not sure, but anyways I would try LOOKUP([_THISROW].[CUSTOMER] etc…

1 Like


@khuslid Not working…

Also, it shows success here when there is an error.

Ok, I asume you get a green “Check” symbol in your formula in the editor?
And that all table name and column names are spelled right.
And no sec filters blocking (you can “Bypass securityfilter” in the task)?
And you use << >> around the formula in the template?

Sorry, no more clues…

Always does… One must use the Automation monitor…

Even I’m out of clues.

But your error is in Body template.
What do you have there…?

Same formula wrapped with << >>

Everything was working fine until i moved it to automation bot. Here is another example that is causing me error in a delivered application :face_with_head_bandage:


Works perfectly inside app. Whenever i use lookup i get an error now. I had this working fine before.

Maybe try ANY(SELECT… and see. Should give the same result.

1 Like

Unbelievable.

Attn @prithpal @Dan_Bahir @praveen

Any(select ()… ) Always works. Lookup is showing me the error.

1 Like

This is definitely a bug. Please contact support@appsheet.com for help with this.

3 Likes

I will take a guess that the response to the success when it fails will be that the bot “successfully started” and is not indicated “the bot successfully completed all tasks”. I have seen somewhere that that was how it was described.

1 Like

For lookup i can use ANY(SELECT(),…) Function. But I notice this error for the first time.

Also, here is the images for reference.
Sales Invoice template

Sales Table

Customer Table

Error

Hi Rifad,

Could you send an email to support@appsheet.com, provide the App Name, UserId, Bot Name and allow support access to your app?

We will debug this issue and get it working for you.

Thanks

3 Likes

Done @Dan_Bahir

1 Like

I don’t see it mentioned here…Did you try inserting explicit quotation marks around the second, third and fourth parameters of the LOOKUP(). Leaving them off is really a shorthand approach within AppSheet’s parsers.

1 Like

Yes i tried and it did not work @WillowMobileSystems

1 Like