Automation Monitor takes 2 min to sync

Is anyone else experiencing sync times above 60 seconds on the Automation Monitor App?

Mine is taking between 1 and 2 minutes to load.

@Dan_Bahir — FYI.
Stefan, I think this is a known problem that happens in accounts with many apps (like yours and mine!). Dan is working on a fix.

3 Likes

Ah! That makes a lot of sense. I suppose that’s also the cause for some slowness in the MyApps and MyAccount page.

Thank you for the clarity. :+1:

1 Like

Also please familiarize yourself with some of the user settings that you can additionally set to control the date range for the data. Please check out this help article on how to configure that.

2 Likes

Hi Stefan, the MyApps page should be fast. If not, LMK the details and I can take a look.
For the automation monitoring app, there’s more work being done to fetch and analyze each app dynamically andthat really slows things down. That’ll get optimized in a hurry now. Much of the focus so far was on the functionality of the monitoring app.

3 Likes

@Dan_Bahir - any update on this? My automation monitor doesn’t even load anymore.

2 Likes

Hi Stefan,

We have added you to the rollout on a loading optimization for users that have many apps. It should take affect tomorrow. I will update you once its rollout out.

Dan

3 Likes

Much appreaciated!

Its been rolled out, please give it a try.

1 Like

Thanks @Dan_Bahir

I’m noticing no improvements as of yet. Just tried opening it in a freshly opened browser

Hi Stefan,

We released a better optimization tonight to improve the performance/latency of the monitoring app now. Please give a try.

Thanks!

1 Like

Hi All,

Is anyone else experiencing sync times above 60 seconds on running google scripts?

It becomes very slow as from last night. I live in Perth Western Australia and was programming last night from 12 midnight to 2 AM. Even Google Sheet was so slow for calculating 1+1 for a while.

Also, sync times were increasing 20 to 40 times longer than what I measured before.

I was wondering if I should wait a bit more or search deeper to change the codes or something else?

1 Like

Absolutley agree!
Extreemly slow! (And specially outside US).
Using a VPN to US improves significantly.

And it takes me 7 minutes and 52 seconds to open the page My Account.

I’m seeing major improvement from that release.

My load time is around 10-15 seconds.

2 Likes

Mine appears to be fixed as well.

2 Likes