Ayuda con una formula

Necesito ayuda con una formula que no me funciona
Tengo en mi hoja de aplicaciones una tabla donde registra movimientos Fecha, importe y estado, dentro de mi hoja de aplicaciones tengo la siguiente formula:
=SUMAR.SI.CONJUNTO(comisiones!B:B;comisiones!A:A;">="&A2;comisiones!A:A;"<="&B2;comisiones!F:F;"=Pagado";comisiones!F:F;"=Adelantado")
mi resultado de esta formula es 0
Mis registros en esta tabla si tengo registros solo pagados y da cero en la formula
Intente lo mismo dentro de la formula en la aplicacion de apsshet y pasa lo mismo esta es la formula en appsheet:

y mi resultado es cero y si tengo registros con estado pagado, algo curioso en la formula es que si quito la condicion de adelantado tanto en appsheet como en google sheet si me da correcto

alguien sabe algo al respecto gracias

Buenos dias,

No sé español, así que espero que el traductor de Google sea lo suficientemente bueno. Tu expresión tiene una condición que nunca podrá satisfacerse. dentro de su función “and”, “Estado” no puede ser igual a “Pagado” y “Adelantado” al mismo tiempo. Creo que desea que la condición verifique si “Estado” es igual a “Pagado” o “Adelantado”. Para hacer eso, querrás algo como:

and(... otras condiciones ..., or([Estado] = Pagado, [Estado] = Adelantado))

Espero que esto ayude.

3 Likes

Hola, yo creo que deberias poner el Estado=‘Pagado’ entre comillas simples o dobles, no recuerdo bien cual de las dos.
Probalo, eso debería dar el resultado que esperas.
Saludos

1 Like

Hola! Si, yo creo que el problema es que debe ser “Pagado” y “Adelantado” en lugar de “=pagado” e “=adelantado” como dice @feder

muchas gracias

1 Like

muchas gracias.

1 Like

gracias

2 Likes