Blank columns showing up

Hey all!

In my detail view, I am having some columns with blank cells showing up and I’m wondering why.

Is there a place I can control this in settings? I thought it was Appsheet’s default not to show columns if there is nothing input for that row?

Many thanks!
Miranda

You can find the reason from UX > Options. The option name is "Apply show-off constraints universally. You probably have it as ON.

@Aleksi Are you sure?
I find 2 possible settings:

  • Apply show-if constraints universally
  • Include Show columns in detail views

But even when I enable both, empty columns are NOT visible in detail view.

Do you have anything with the Show? option or are they all ON?

All ON

Try to change some of them… with a formula

For example if you type “TRUE” to Show?, it should show that column even it has no value.

Looks like I’m having the reverse problem. I unchecked Apply show-if constraints universally, and I also unchecked Show within the column structure.

The two columns in question have a SELECT expression in them. Do you think that could be the reason why they are still showing even though the value is blank?

@Miranda_Lubarsky If the Show? option is set as OFF, it should not show your column.

1 Like

Yes.

But they still show. Show is also un-checked in the Column structure. Yet it still shows. Could the SELECT expression in the column structure be interfering with anything? It’s the only thing I can think of.

What is the column name that you are referring?

There are multiple columns that show even though there is no value in the cell. But it includes “Deer: Will They eat It?”, “Pruning”, “Trellising” and “Pests”.

If the option “Apply show-if constraints universally” is set to OFF as you said… do you have any expression etc. with Show? option with these columns?