Blue dot won't disappear and can't save app

I’ve looked everywhere and trust me there is absolutely nothing I can do. As of right now, despite the fact that this app would’ve been amazing for my business, I can’t use it. I can’t even save the app at the very beginning stages. The absolute beginning part of the development and I’m already hindered to the point where I literally cannot use the entire app. I’m sorry, I just got really excited about this and now I’m really frustrated lol. As a full-stack software developer myself, I strongly believe something like this could’ve been caught and debugged waaay before the app was pushed to production. As you can see, I have 19 screenshots because I literally covered every single pixel of the pages. Nothing. No inclination whatsoever what I need to do, and even worse, no ability to fix it. I’m stuck…

There are no tooltips available, by the way. I’ve double triple quadruple quintuple checked this. I’m 99% sure it’s a bug. I’m just shocked that I’m getting this bug and no one else is. What could I possibly be missing? I’ve looked over all of it for more than a half-hour straight.

Are you talking about the blue dot next to “UX” and “Views”? That just indicates there is a suggestion for you. They can sometimes be helpful for new users, but it definitely doesn’t mean you have to do anything. You can freely ignore it.

As for “can’t save app”. Sometimes (rarely) the Save button doesn’t like to light up when you make a change. Refreshing your browser page usually fixes this.

1 Like

Yes that blue dot. So the blue dot is for tool tips. I was getting the interaction where I closed a tool tip and the blue dot left once… but since then, no. I’ve acknowledged and closed or made the change for every possible tool tip and the save button still won’t light up. I’ve checked a trillion times. No more tool tips, still blue dot. When I refresh the browser, I lose all the work I just did. None of the views or any changes I made are still present.

Are you saying the blue dot is not the reason I cannot save? Like, I should still be able to save even if there is a blue dot? And it’s the save button functionality that is shorting, not the tool tip part?

Yes, the suggestions and saving don’t really have any relation to each other. Dismissing a suggestion is not an edit to the app, and thus does not require any save.

1 Like

I see. That is what I’m experiencing now and I’m able to save the app. I guess now the question becomes for me: why is the save button randomly not working and what reliable workaround do I have? Refreshing the browser does work but everything I’ve worked on is lost. It’s like I make changes, I’m unable to save them, I refresh the page, I’m able to save now but my changes are gone.

I’m assuming somewhere within the components I created there is a key functionality piece that needs to be addressed that isn’t addressed which is graying out the save button. If that is the case, I’ve still not been pointed whatsoever to what issue is holding up my save.

It just happens sometimes. Like I said, rarely, but it did just happen for me this morning as well. Could perhaps be due to some issue on Appsheet’s servers? If it happens, then yes you have to refresh and lose your work.

This is incorrect.

1 Like

Okay well it is what it is. Thank you very much for taking the time to talk me through this. I’m not as upset now :joy:

1 Like

Sorry for disturbing, but taking a look into your screenshot, im just wondered which browser you are using to interact with appshee editor.

My understanding is Chrome is THE most lowest chance to see a bug with Appsheet, but not sure which browser you are using to play with App.

Different browser (not chrome) gave me bunch of headache in the past, so I ponder you problem might be coming from brower you are on.

1 Like

Ahhh interesting point. I’m a developer so I’m fully aware of the browser compatibility issues. I didn’t think of it at the time but that definitely makes sense. My Chrome is broken and I can’t fix it :frowning: Off to the next forum! :joy: :joy: :joy:

Browser compati is one of the major factors when we play with AppSheet. This is common problems across any other services.
If you use IE, no hope, probably, seeing bunch of issues which are unexpected.
Your browser icon (on screenshot) not telling me which browser you are on, but highly likely your issue is comin from there.
(Based on my past experiences)

2 Likes