Blue 'my location' dot moving around in map view

I am wondering whether others also experience problems with the behavior of the blue dot indicating the current position in the map view. My feeling is that it is becoming worse in the last months. Maybe this is because I switched to Android 10?

My issue: While doing a short walk outside without good internet connection (so not in a city) the blue dot is jumping around within seconds. Then moving slowly back to another location, still not the correct one. Partly the shown locations are several kilometers away from the correct location. Partly the dot is completely outside the map or seemed to be frozen in a complete wrong location. The changes happen within seconds very often, sometimes a position looks stable for minutes although I am walking during this time. More interestingly other apps like Google maps and Locus map are really stable showing the correct location. (had booth views in parallel on my smartphone)

I am aware that Appsheet uses the Geolocation API and I tried already several browsers as standard - Chrome, Firefox, DuckDuckGo. But finally they all give me such problems.

I am using a Xiaomi, Redmi 8 with Android 10.
I tested as well with an older version of Android 8 with a Motorola smartphone. That looked much better.

Any others with the same issues?
Am I missing something I need to check in my configuration?
Any suggestions to improve the accuracy? (high accuracy is enabled in Appsheet settings already)

Thanks a lot

I made some further testing and searching. The “geolocation api” should work on my Android phone with Firefox, Chrome and Opera and on IOS with Safari. DuckDuckGo seems not supporting fully the API.
I tested as well onsite and found that it is working in flight mode. That means only GPS is used. You may find this in the attached image sequence. It starts in flight mode with correct location. Then I switch flight mode off and the dot moves to a completely wrong location. And I was not walking around in this 20 seconds.


For me it looks like a fault in the geolocation API.