Bot report mail for every row how to stop this

I created a BOT, schedule event for an specifica hour every day.

If I cheched ForEachRowInTable It sends one mail for every row and I just need one report according to a template.

If I do not check ForEachRowInTable then I get the error that the Event and the task are not compatible.

Help with this

Hi @jujogar10

You need to set a “None” table to your process and event.
Untick “for each row” option in the Event.
And change your template in order to run on the whole table.

You may want to use an expression in your template like this:
<<Start:FILTER("YourTable", yourConditionExpression)>> <<[column1]>> <<[column2]>> <<End>>

If that’s not clear, please share screenshot of your bot configuration and template, that may help into guiding you on the right track.

For reference:
Section " Select Expression"

3 Likes

Very clear and now the report it´s OK, but my next step is to flag the records sent in the report. For what I understand I need to make another bot to make the data change since with this event I cannot use processes that affects data. Is this the right approach?

Hi @jujogar10

Happy to hear you succeeded.
About that:

That makes sense indeed, although there might be various way to proceed, as often :slight_smile:

In this case, I would fire this second bot first, and wirte down a timestamp that will then be a part of the condition for your first bot, if you get what I mean. Something like
DATE([TimeStampTrigger])=TODAY()

2 Likes