Bot to Create Document using a slice is not 'slicing' the information into my template

Important to note: Today is 8 JUNE 2021 - this will come into play I promise.

I am not sure what I am missing. Going over this, I am going to assume the issue will be in the “Processes” section: looking for a trained eye to slap me on the back of the head and say dummy.

My bot, creates a daily manifest for drivers

It has one process, and that is to create the file:

When I choose to go to the task via the link at the bottom:

image

I am taken to the task I need (want?) it to run.

Pay attention to the table name - it is a slice.

When I run a test, it creates the document, in the template format I specified, but the data from the table (slice) is not matching what is shown on my created document. The information is all from todays date.

The UX view of the slice shows the correct information (data for the 9th)

image

If I view the ‘process’ the bot created, it is asking for a table association

Unfortunately, the ‘slice’ I want to use is not listed.

image

If I change the table to a choice other than “None” it breaks the bot.

What am I missing to get tomorrows data to show up in my report?

does the output report contain the 8th and the 9th? Or is it only containing the 8th?

@Austin_Lambeth

Only the 8th.

It might be a time difference from the server and the device in the formula. Normally this would go the other way though. Can you try making a new slice that is 1 more day in the future? Im not really sure where this is changing the date but a possible solution is make 2 slices with 1 being 2 days in the future.

Can you post your whole slice formula?

AND (ISNOTBLANK([DVRCALLSIGN]),[date]=workday(today(),1,(Holidays[HOL_DATE])), [FUNDINGSOURCE]<>“CANCELLED”)

I changed it to:

AND (ISNOTBLANK([DVRCALLSIGN]),[date]=workday(today(),2,(Holidays[HOL_DATE])), [FUNDINGSOURCE]<>“CANCELLED”)

When I run the bot, the data is still from the 8th.

If Change the slice to

AND (ISNOTBLANK([DVRCALLSIGN]), [date]=(today()+1), [FUNDINGSOURCE]<>“CANCELLED”)

The data on the form is still from the 8th, but the data in my UX is from the 9th.

Is the report the exact same when you ran it with the 1 and the 2? If it is that may indicate the problem is something different.

I don’t have a ton of experience with reports so it may be somewhere in the template itself not the slice.

This appears to be related to this thread Automation Slices

@APiCC_Conor the topic doesn’t quite reflect my issue; however, it is good to know :slight_smile:

It looks like you’re generating the file via a template. Why don’t you just reference the appropriate records/slice in the template. What do you have in your template? Is your schedule Event “for each row in table”, or not?

1 Like

My template is pretty simple, I think.

and BAM! Just like that, I found what I was doing wrong.

My Template has a select() function - and it was referencing the WRONG table (Driver Manifest in this case).

So my error is rooted in my noobness.

I did not understand that when I reference the ‘template’ in my processes, tasks, bots, etc. that the template is not automatically linked by the system. I had to manually associate the template to the right table.

Ok, so… who wants to slap me in the back of the head now?

Thank you for all your help.

2 Likes