Bug report: SELECT a List of Refs return nothing

Recently, I’ve found a bug like this:

  • Table CLASS have a [Students] Column, which is a List of Refs to table STUDENTS
  • In a CLASS, I use SELECT([Students][Name], TRUE) to get list of student name. It worked before, but it return empty now

If [Name] column is the Label column in your STUDENTS table, you can use:

STUDENTS[KeyColumn]

OR

SELECT(
    STUDENTS[KeyColumn],TRUE
)

in your Valid_if expression.

That suggests either the Students column list is empty, or its values are not valid Ref values. Have you perhaps recently changed the key column of the table these values reference?

1 Like

Here is the issue I’ve found:

  • table A have these columns: [ID] (as Key), [content_a] and [ID_of_table_B] (ref to table B)
  • table B have these columns: [related_As] (Expression: REF_ROWS(“A”, “ID_of_table_B”)) and [content_b]

The Expression of [content_b] is:

"this is list of A's ID: " & SELECT([related_As][ID], TRUE) & " (" & SELECT([related_As][content_a], TRUE) & ")"

It worked before (about 2 days ago) but now the result is somewhat empty like this:

This is a row of table B, some value is missing in [content_a] value

1 Like

Then after a sync, this row becomes this:
image

Try a new sync, and the result:

The [content_b] seems to change randomly after a sync

2 Likes

Please contact support@appsheet.com for help with this. This may be a bug.