Bug: Shceduled bot not selecting a data action to run

I am trying to create a bot that will add a new row to a table on an scheduled basis.
When I create the new step “Run data action”, the settings page on the emulator goes blank and it will only let me select the option “Create new action” but, after I create it, it wont let me select the action.
Also wont let me select “Add new rows” as the type of data action to run.

Update:
So it won’t let me add “Run data action” steps from the main process in the bot settings. I created a new independent process from the Processes tab and then called that process from the bot, that way I can now edit the bot.
Not sure if it is a bug or just the way it is supposed to be now in this new design for automations.

Update 2:
Trying to create a bot that adds rows on a scheduled basis will only work when creating a new process alone and then creating the bot and calling that process… The thing is, when calling the process from the bot there are 2 options (Add and lookup). When choosing Add, the workflow will add two identical rows, one from the bot and one from the called process; when choosing Lookup it wont call the process so it runs but does not add any row.

So not a bug, just a design flaw maybe?

1 Like

You can just have an empty process (Process with no steps) and call that with Add. That way it will only add one row.

Thanks for bringing this up, we will think on how to improve the option to allow your usecase in a simpler way.

Dan

2 Likes