Calculation Slow!

expressions
(Lavanderias El Sol) #1

Hello friends…
I have a lot of time using my app, and I realized this weekend that there were many capture errors and when analyzing the reason I found the following …
We capture a quantity, and the app evaluates the amount (quantity per price) and later it is part of a virtual field. But if I press the save button, before the changes are reflected, it does not save the change !!!

Before the calculation was much faster!

What i must do to avoid that ?
Do i wait until the calculatioin is done to press the save botton ???
i have a video where you can see it…i only can send pictures…

(Aleksi Alkio) #2

Please send a link to that video, thanks.

(Lavanderias El Sol) #3

(Lavanderias El Sol) #4

Aleksi, THX for hoy Quick responde, i already senda they link (MP4 on Google drivers)…

Thais is

Do you can see it ?

(Aleksi Alkio) #6

Unfortunately I’m not able to see it. At least I’m not able to open that link.

(Sebastian Tiller) #7

@Efren can I suggest you use https://www.useloom.com/
It is free and very easy to use to make shareable videos.

(Lavanderias El Sol) #8

sorry for being late, the video is ready, but i had issues with the share…

(Lavanderias El Sol) #9

this is the video…

(Lavanderias El Sol) #10

here are again in gif format,

https://drive.google.com/open?id=11Gg4uQJJuBvBN4odFudk_owqKCmtT-5V

(Aleksi Alkio) #11

This should be solved issue for few days ago. Have you tried your app lately?

(Vlad Roman) #12

This issue i’m having on my app as well. First i thought is because my formulas were to heavy so the calculation was taking some miliseconds more but i did not made any changes to formulas. it’s been happening for a week now. Basically now if i increase the quantity for a product in a form and i hit save fast, the price and the quantity is not saved with the new values. It takes some time to calculate. This wasn’t an issue before.

(Aleksi Alkio) #13

If you wait 5 seconds before pressing the save, does it work then?

(Lavanderias El Sol) #14

If I wait a few seconds for the formulas to be calculated and shown on the screen, and then press the “save” button, everything is correct …

(Aleksi Alkio) #15

Thanks for this info!