Calendar view issue. I've noticed that calen...

ux
(David H) #1

Calendar view issue.

I’ve noticed that calendar view just went blank or it shows up and does not show any date (events).

Whichever data I choose to attach to it - it just won’t work. It worked two days ago perfectly with date of event attached to start date. Could this be a bug or an issue on my side?

Thank you in advance.

(Simon Robinson) #2

I have exactly the same issue in 2 Apps.

Both created this week.

Calendar was working fine, changed nothing, now both blank. @praveen @Harry

(Samsson Freed) #3

About two weeks ago I tried connecting my first Calendar View table.

I am able to see the data from the table in any view except Calendar View. None of the events appear in the view. I’ve not received an answer to my post here: plus.google.com - I created a calendar table with columns that mirror the Calendar View Sample … I created a calendar table with columns that mirror the Calendar View Sample … plus.google.com

(Samsson Freed) #4

@Aleksi_Alkio In my case I am unable to choose a category option beyond the two choices “auto” and “none”. The screen shot I took was unable to capture that condition for you because upon clicking to activate the Snippet application, the selected Category dropdown disappeared.

That said, ‘auto’ and ‘none’ are the only two choices available for Category - even though I do have a text column called “Category”, which does appear in all of the other column designations - including ‘Start’ and ‘End’ times/dates as well as the other text field, ‘Description’.

Looking at my table, ‘Category’ is its last column and it had no data. I therefore populated that column with fake data for every record and then regenerated the table in AppSheet hoping that this would make the ‘Category’ column available to AppSheet for designation as ‘Category’ in Calendar View. Unfortunately, I still only have the two choices ‘auto’ and ‘none’ and cannot see any data in Calendar view even though I can in any other view.

The last thing I tried was to go ahead and select ‘auto’ as the ‘Category’ column designee. This is in fact the way it was before (as one would expect: ‘auto’ is selected by default). I wanted to be sure however, that there would be no difference in forcibly selecting the option from simply allowing its selection by default. I therefore selected ‘none’ first and then saved my changes. I then re-selected ‘auto’ and save my changes - again to no avail. I simply cannot choose any option other than either ‘none’ or ‘auto’ for the category column and still cannot see any data in the calendar view.

(Samsson Freed) #5

@Aleksi_Alkio I should have mentioned in my previous post that I have two column constraints defined for my ‘Category’ column: ‘text’ and ‘searchable’. No other constraints are defined for this column and all of the records have one of two words as data entered within all records: ‘Service’ or ‘Development’.

(Samsson Freed) #6

@Jeff_Drouillard By ‘trouble with the wording’ Jeff, do you mean that you cannot select a choice beyond the ‘none’ displayed for ‘Start Time’ and ‘End Time’?

(Aleksi Alkio) #7

Change the Category column as an Enum and it should start to work.

(Samsson Freed) #8

@Aleksi_Alkio Changing ‘Category’ column to Enum fixed the problem of allowing its selection in Calendar View, but data still fails to display in Calendar View - even after saving changes and clearing cache.

(Aleksi Alkio) #9

@Samsson_Freed What is your account ID number and app name if I check it quickly?

(Samsson Freed) #10

@Aleksi_Alkio Account ID: 742965

| App Name = “Sams Son Freed”

(Aleksi Alkio) #11

I tried to reproduce the same behavior but I couldn’t. I need to ask our developers to check the reason.

(Samsson Freed) #12

@Aleksi_Alkio Thank you, Aleksi. You might be interested in knowing that after you posted this your most recent message, I logged off of and logged back onto AppSheet. This resulted in no change to the problem.

(Brandt Litton) #13

Just since it seems related, I was looking at the sample app “Local Events Calendar”, and the calendar side of it doesn’t seem to be working either.

Just shows completely blank.

(Aleksi Alkio) #14

Adding @Morgan_Dixon_AppShee

(Samsson Freed) #15

@Brandt_Litton I just now visited the Local Events Calendar sample app as well with similar results to you, Brandt (just a blank screen).

This is somewhat different than the problem with my own app, in which I can see the calendar boundaries and the numbers that correspond in each cell to their respective dates, but can not see any of the events displayed.

(Morgan Dixon [AppSheet]) #16

Hey everyone, I just fixed this issue and it will be deployed within the next few minutes. You may need to reload your apps to see the changes. Thanks for your patience.

(Brandt Litton) #17

Thanks! @Morgan_Dixon_AppShee!!

Lookin good now

(Jeff Drouillard) #18

I seem to still be having an issue.

I did reload the app and did see some changes to the menu entry so I believe I am seeing the latest fix.

Mine must not be working because my start time and end time ,uses a date/time field type and it must not be recognizing that.

It did work a week or so ago when there was an option for “auto” to be chosen in those fields

(Samsson Freed) #19

@Morgan_Dixon_AppShee Unfortunately I see no change, except perhaps that I now am suggested by the app’s UX to sort and group table rows - although I see no option within the Calendar View’s definition for specifying those parameters beyond clicking on ‘Sort Rows’ and/or ‘Group Rows’ as shown in the screen shots. I don’t recall seeing those options before Morgan’s work but I’m not sure about that.

I have appointments scheduled on 11/11/18 as well as on every day 11/22/18 - 11/27/18 inclusively.

The screen shot shows no data displayed for those or any other days.

(Samsson Freed) #20