Cannot find error "The given key was not present in the dictionary."

I have suddenly gotten this error. Cannot find it in any table or …anywhere.

Just shows the red “error” dot next to “Info” “Data” and the “Columns” tab of the “Data” interface but I’ve opened and scanned every single row looking for the source of the error and I can’t find a single table row that is red with the error flag.

No clarity from support dbase. I can’t upload any new tables without getting an error when uploading that same error over and over.

WTF?

App is: QuoteBuilder-171176

Totally stuck. Been trying to figure it out for 30 minutes now. HELP!!!

It looks like a bug. We are investigating.

1 Like

@Todd_Stone The immediate cause of the issue is that a few of your tables (Contract Status Types, Cost Item Master List, and Contract Types) are not correctly associated with their column structure.

The root issue is probably something to do with renaming tables. Did you happen to rename any of those tables?

I’m going to try to fix the root issue. In the mean time, as a workaround, could you please try removing those tables and then adding them back to your app? Let me know if you encounter any issues doing that.

1 Like

@Todd_Stone Part of the bug has to do with adding two different worksheets that have the same name (e.g. Sheet1). As a further workaround, you might want to rename the sheets for the tables you’re re-adding to be distinct. Thanks.

1 Like

@Todd_Stone I believe I’ve found the root issue and put a fix in for it. It will need to go through our nightly tests before we deploy it. In the mean time, please try the suggestions I gave above to work around the issue.

1 Like

I can do that BUT obviously that means I’m going to reprogram all of the associated relationships. I’m not understanding why the table restructure wont fix it and more importantly, why won’t it tell me where the error is?

I’m unclear as to why the name of the tab would be relevant. Same issue. Just about every tab I have in every google sheet is named the default “Sheet1”. Will changing the name of the tab break all the downstream relationships that are based on this worksheet.

I don’t understand why (unlike how it used to be) the table name default that appsheet places it into the system with is now the name of the tab, not the name of the worksheet or if necessary the name of the worksheet/tab?

Ok. Just tried deleting them and restarting the app. No, I didn’t re-import them because if the source of the problem was those tables, then deleting them should get rid of that error and instead give me a bunch of other errors based on the missing tables that are referenced…didn’t happen. Same error. Theres a bug somewhere. It’s REALLY frustrating to have an error that is racking up a bunch of my time and it shouldn’t be there and it won’t give me any direction on how to solve it.

Since I still have the error and deleting those tables didn’t help, can you provide some kind of an update?

Work arounds didn’t help. It’s a bug. Can I get an update?

Hi Todd. You’re right, it’s a bug. Still trying to fix it.

The details: When you add a table (say, a table called Customers) it also gets a set of columns associated with it (called Customers_Columns). When you rename the table (say, from Customers to Clients), it keeps the same name for its columns (still Customers_Columns).

The bug happens if you then add another table called Customers (different than the original Customers table). Now both Clients and Customers are associated with Customers_Columns. I believe this is what happened with your app.

I put in a fix. But the fix introduced new errors that I still need to address. So I’ll still need some time to get this issue fixed completely.

In the mean time, can you roll back to an earlier version of your app that doesn’t have this issue? Then, when you add new tables, you can work around the issue by ensuring that the new tables you are adding do not have the same name as a previously renamed table.

1 Like

It was a prototype app. I don’t have any older versions saved. Is there a rollback or restore feature or would I have needed to actually save a prior version?

You have to realize this is a pretty major bug if I can do something that actually “breaks” the app and the only fix is a reverting to a prior version (which I’m thinking can only be done if I had the foresight to create backup versions…which I did not…as I didn’t know that an irrevocable error could even take place.) Quite an issue for a program meant for “non-developers”.

I still see the error so it seems like what you’re telling me is I have to rebuild the app from the ground up in order to resolve this?

I have to say that REALLY sucks. Days of work lost.

1 Like

Also, why did you stop automatically naming the tables based on the names of the underlying name files? Since google won’t let me create duplicate named files in the same folder, and all my source tables are in the same folder, then this issue would have been automatically avoided, wouldn’t it (unless I chose to name the table something else)?

@Todd_Stone
Have you checked Manage >> Versions >> Version History pane for older versions of the app? Because with each save in the app editor, a new version is created.

Thanks. I’ll try that.

Nope, only one version there. I’m not sure what you mean by “each save” because I’ve done like hundreds of “saves” on the app prior to the one that broke it.

I’m assuming there is something I have to do to save a version, but I have no idea what that is.

Hi Todd, do you know the approximate date of the version you would like to restore? I can get it back for you. AppSheet keeps a version history for all apps, though the history window is limited based on plan type. However, if you give me a date I can restore it for you.

I’m sorry that you got bitten by this bug. There should be no irrevocable errors in AppSheet, but occasionally we need to fix a bug like this one.