Cannot transfer a created app to another author/DB

Good Night everyone. Sorry for the long post, But I am quite desperate here…

I´ve made an app for another person using my account, its is using a google sheets as a DB so it is linked to my google drive and it is working working fine as it is.

However the app saves pictures and videos that take up space on my google drive, so I want to transfer the ownership of the app to the app user, that way all the files will be stored in his google drive account.

I´ve followed every method described here : https://help.appsheet.com/en/articles/962317-moving-apps-between-data-providers

But I can´t get it to work…

Here is what I have done so far:

• Copied all the folders regarding the app to his drive using the same folder path structures, then I gave him the authority over the app. The app simply does not work, it shows an error saying that it cannot find the data to any of the tables. So I checked the tables structures and the tables were there but they were not set to any file (just like a new blank table). So I edited each one of the tables to make sure they were pointing to to the right file. By doing so the red circles over the data indicating an error disappeared. So there were no erros to be found inside the app however the app itself did not work, it was stuck on a page saying it was not possible to find and read lots of files… So I tried the second way, described in the link provided…

• I undone everything I had done before, I set him as co-author , logged into his account and tried to copy the app checking the “copy data box as well” that way all the app and data would be copied to his google account. But then I got the fofllowing message :

{ “error”: { “errors”: [ { “domain”: “global”, “reason”: “notFound”, “message”: “File not found: 1SwwyCgHLPT-TD177lZBU7N_cGnuydS-v.”, “locationType”: “parameter”, “location”: “fileId” } ], “code”: 404, “message”: “File not found: 1SwwyCgHLPT-TD177lZBU7N_cGnuydS-v.” } } → Unable to create application folder ‘/appsheet/data/Controledeatendimento2-1815260’ due to: { “error”: { “errors”: [ { “domain”: “global”, “reason”: “notFound”, “message”: “File not found: 1SwwyCgHLPT-TD177lZBU7N_cGnuydS-v.”, “locationType”: “parameter”, “location”: “fileId” } ], “code”: 404, “message”: “File not found: 1SwwyCgHLPT-TD177lZBU7N_cGnuydS-v.” } }

So I tried it once again, that message did not show up but I got another error saying:

" Error Cloning App
Unable to read table ‘Pacientes’. → Unable to copy external files due to: Unable to read table ‘Pacientes’. "

So I gave up on that method, undone everything I had done again and tried the following:

• I´ve shared all the folders on my drive with the author-to-be, and transferred the app to him. It shows up as his app and the app works fine, however the DB is still linked to my drive so If I end up deleting anything on my drive regarding to the DB the app crashes and stops working. Since the app was working this way (So I was sure it could read all the files and work correctly) I tried to copy it once again (now as the only author) and got the same messages from the previous try.

So I don´t know what else to do… My last resort would be recreate the whole app from scratch using his own account , that way everything is linked to his google account, but that would take so long…

Has anyone experienced the same ? Or can anyone give me a hand ?

Best regards !

Have you checked this article about the 404 error… https://help.appsheet.com/en/articles/962250-issues-with-google-drive

1 Like

Please contact support@appsheet.com for help with this.

Didn`t see that post, I am going to check it tomorrow, however I tried to make the app completely from scratch using his account, just to test (new sheets just with a few columns filed with random data), just somehow got a similar 404 message.

I dind’t do anything unusual, just selected make an app based on a data source, pointed it to the sheet in question and then got the error…

Tried a couple of times to no avail, but a little later that new sheet appeared as a "recommended " sugestion for an app… And by clicking on it it simply works… which leads be to believe that google sheets and the sheet itself is fine… since it can be accessed and used normally now, but for some reason I can’t manually select by datasource (and because of that I cant copy or give ownership to another person).

Gonna contact them , Thank You.

AppSheet reads the Google Sheet by asking Google to “export” the worksheet as a Excel .xlsx document. Google converts the Google worksheet into an Excel .xlsx document file and returns this .xlsx file to AppSheet. AppSheet reads the .xlsx file and extracts all of the worksheet cell values, formulas, formatting, and other information from the Excel .xlsx document.

I’ve read previously from some other AppSheet team member that performance-wise, outside of a dedicated database, AppSheet performs better with Google Sheets over Excel. But if a Google Sheet has to export to .xlsx before being read, how does a dedicated .xlsx file not outperform the Google Sheet? Or is that performance hit moreso related to the cloud storage choice?

To put an end to this, today (3 days after my first try) I tried once again, did exactly the same steps I had done on the first try and it just worked fine … go figure.

The only thing that crosses my mind is that the first time I tried has just after a server maintenance on Appsheets side (on Sunday). Maybe it was a result some sort of bug that ended up being fixed soon after.

Anyway thank you for everyone’s support.

1 Like

Seems likely to me. Let’s go with that! :wink: