Can't view PDF files on iPhone... ask me to Download them!

Hi Community:
I am struggling with a problem that I cannot understand. I have created an app that generates a PDF report of work orders, it works quite well, or rather it worked quite well until yesterday, since it does not allow me to see the PDF files generated via workflow.
I have made several apps that generate PDF files that can be perfectly visualized both on mobile phones and on desktop PCs, that is, I have proven that it works very well regardless of the device or platform that the users use.
The problem now: on mobile devices, it does not allow me to “view” the PDF files and forces me to “download” them on my mobile or tablet. Is this normal?

The PDF file is generated correctly!!!, it is saved at destination folder and can be viewed ONLY from the desktop app.

To fix it, I have tried:

  1. Check the “Automation” procedure to create “bot” (OK)
  2. Check the paths to save the file (PDF) (OK)
  3. Review security options (OK)
  4. Reinstall the PDF reader application on the mobile and tablet (OK)
  5. Check the app cache (OK)

Worst of all, I tried the app on another iPhone and it works perfectly. I feel lost in the actions that I must follow.
Anyone with any ideas that can solve this issue?

Thank you.

I have the smiliar problem.
After this message, I click “OK”. Then the pdf is opened but can not take any action… I can not share, I can not print and can not close the view and return to Appsheet.

I must close Appsheet app and open it again…
This is the only thing I can click (It means “OK”) but no response