Certificate Error: Not Secure - on My Apps Page

The My Apps page has a certificate error in Chrome, saying the connection is not secure (even though it also says certificate is valid).

Screen Shot 2020-06-30 at 9.19.40 AM

But the editor, My Account, and the app itself all are working normally. It’s just the My Apps page.

Screen Shot 2020-06-30 at 9.25.50 AM

@Aleksi, @Steve, is this normal? It’s a bit concerning but I don’t know if it’s new or I’m just now noticing it.

Just tested in the Brave Browser and got the same results when using the same account. Then I tried another Gmail and there was no error.

The one with the error is a GSuite account with a custom domain, whereas the other was a standard Gmail account.

Can anyone else with a GSuite/Custom domain login confirm this behavior?

Hi @GreenFlux, It seems mine still ok. I am on GSuite account with custom domain and chrome.
image

1 Like

I’m unable to replicate the problem with Chrome. Do you have an alternate internet connection to test from?

Same results when tethered to mobile. Good idea though.

[EDIT] Also confirmed the same error from another Mac/Chrome.

The error you’re getting indicates that there is at least one component of the page that is retrieved from the server using an unsecured connection (e.g., HTTP rather than HTTPS). The verbiage suggests the affected components are images.

In Chrome, this setting is enabled for me (by default, I believe):

image

Mine was set to Block Insecure content by default. I tried Allow but that made no difference.

I’m at a loss, then. :frowning: You could try support@appsheet.com, but I suspect this may be out of scope.

UPDATE

It was insecure image links in a few of the app’s icons. The My Apps page was affected since it shows all the icons. I changed the image links to HTTPS and the warning cleared.

3 Likes

Whew!!!