ChangeTimeStamp

Hi guys! Thanks in advance because I know this is a simple fix and I’m just failing.

I have been using this formula =IF(B86<>"",IF(D86<>"",D86,NOW()),"") for managing timestamps for way too long. It wasnt until today that i realized there is a timestamp option available - heck ya AppSheet! However, I cant get it to work for my app.

  • I have tried a virtual colum
  • I have tried an empty “real” column
  • I have tried a “real” column with text in the cells
  • I have tried taking my app tables from read only to editable
  • & more

What am I missing? I cant even get the timestamp column to show up (Yes, the column is enabled to show).

Hi, would you please take a printscreen from that column’s definition so we could better understand where the reason could be, thanks.

Instead of verifying “Yes”, try TRUE

I changed it to TRUE. However, shouldn’t the column label show up? just like how “headlines” is visible?

the timestamp still does not work. In the photo above the formulas have changed the value of “is it SWIYT” to [Yes] / [TRUE] but the stamp has not updated

Have you tried to change it first to No and then Save. Now if you change it to Yes, it should show up.

I tried both and i still cannot get the column to populate

Two things to consider:

  1. Have you checked the datasheet to see if a value is saved there?
  2. Do you have a Slice used for the view and if so, has the column been added to that Slice?

In case it hasn’t been clear, the way you have the ChangeTimestamp column defined, it will only change when the column [Is It SWIYT?] has been changed TO the value of “yes” (since it is Yes/No column “true” value will work).

So, you would need to have had the column value SAVED as blank or “no” and then have edited the value to “yes” before the ChangeTimestamp column gets updated. OR the value of “yes” set initially on the new row.


Try this. Remove the column and value form the ChangeTimestamp column. This will record a timestamp vlaue for ANY change on that row. Test it by changing anything and see if the value shows then.


One other tidbit. Detail views will only show columns that have values set (unless controlled by a Slice) or set to not show.

1 Like

If John’s proposed fixes don’t solve your issue, I can check your app directly.

They did not work. I gave up for now because I’m at work, but if you can try please do. I made the app available to be accessed.

What is the account ID number and app name?

My (google) Account ID: 1067736
My app name: SWIYT

I appreciate your help with this adventure.

Your screenshot shows a detail view. In a detail view, a column with no value is not displayed (unless forced to display), so as to avoid needless clutter. The ChangeTimestamp column won’t be given a value until the row has changed and the monitored column (is it SWIYT) changes to the trigger value (yes or TRUE).

@Travis I checked your app and I opened one NYSE record and the ChangeTimestamp column is working correctly. It shows the new timestamp. In NASDAQ table that won’t work because that table is read_only. Have you tried to change the NYSE record directly from the spreadsheet? If yes, that won’t work. You need to update the record directly form the app so it could trigger the ChangeTimestamp value.

I see… I was looking for a timestamp for when the spreadsheet changes, so that the files could remain “read-only” due to formulas in each line. Is there an appsheet option to track when the spreadsheet changes from “FALSE” to “TRUE”? This formula works for spreadsheets, =IF(B86<>"",IF(D86<>"",D86,NOW()),"") use interactive calculations, but its finicky and really isnt the best option for taking my app to the next level.

Thank you so much for your time and advice!! I wouldn’t have figure this out.

I am truing this formula in a virtual column for now : IF([Is It SWIYT?]<>“No”,IF([Changetimestamp]<>"",[Changetimestamp],NOW()),"")

Not if the table is read-only.