Chart with data of virtual columns sets blank/error values to "0" instead of "blank"

Dear Community,

I have the following questin:
I have created a chart that. The values for it are calculated within a 30 virtual columns.
Currently if there calculated value is not a figure (for example “–”, or blank “”) the value of each data is shown/set to “0”.


But i would rather have just a blank instead, like here. Unfortunatelly it seems like it just works with physical (real) columns, not virtual ones.


I have tried with decimal("") or just “” or " " to reach the same result within the chart that gets its data out of the virtual columns but it didn’t work. (Unfortunatelly it seems like working with “show if” doesn’t work too, as in my case there are also more than one set of data within a chart.)


Appreciate help :slight_smile:

If virtual and physical columns are handled differently, I’d call that a bug. Please contact for help with this.


Thank you fo reporting this.
@Arthur_Rallu @benhare let’s look at this as we are touching this code… It’s weird that we are handling physical and virtual column differently. I think we need a proper option for handling null values, meaning treating it as a 0 or as a missing value and thus a line chart should join the two existing point and ignore the null position entirely. But that should be an option as Null may have different meaning semantically with different columns (Null as measure vs Null for a dimension type column)

What I have recognized is, it may also depend on the formula of the column (maybe it is just not able to calculate sereval if-loops). If I just type “–” into the column formula it appears correct. But not with an bit of expression inside, like (shown value (absolute or relative) should depend the user button choice):


[Chart_Button_FILTER_01] = “1 M”,
[Chart_Button_FILTER_02] = “Absolute”
[Value_01] / 100,

[Chart_Button_FILTER_01] = “1 M”,
[Chart_Button_FILTER_02] = “Relative”
( [Value_01] - [Value_30] ) / [Value_30]


Hey TDhers,

have there been any updates on that?