Cloud SQL Appsheet IPs Present but not recognized by Appsheet

I set up the Appsheet IP addresses in my Google Cloud SQL instance approximately 2 weeks ago and connected some tables to my application (under construction, not deployed). Everything was working fine and I had access to the data until a few days ago when I received an error. In my app preview I receive an error ‘… Appsheet does not have permission to connect to the database. Please add AppSheet’s IP addresses from …’. I have checked my SQL instance and of course the IP addresses are still listed and when I try to test the existing connection by refreshing the datasource it still gives the same error. Hoping someone has an idea what might be wrong.

Is this the list of IP addresses you used?

If so, then check that the login credentials in AppSheet to your SQL datasource are still valid/present.

Yes, those are the IPs I have listed. I also tried testing the connection again by providing the login credentials, which resulted in the same error.

Can you connect to the database from another app such as an SQL app?

In your cloud SQL server, what area are you inserting the IP addresses? I.e. what is the name of the field on the server?

It would appear that I am able to connect to the same database via a different application.
The IP addresses are listed under my SQL instance Connections tab, specifically under the ‘Public IP’ authorized networks. Please note that this worked fine for over 2 weeks up until late last week, nothing has changed on the authorization side either within AppSheet or within my SQL instance.

I would contact support@appsheet.com.

1 Like

FYI, I have an app that I built against an SQL database that I haven’t used in a while. It is still connecting fine. So it seems it might be something with your specific connection.

Thanks for the assist. I am not sure what is happening and I went ahead and emailed support. Somewhat discouraging since I am one of the individuals that is having to switch from Google App Maker and so far AppSheet has not been intuitive at all for me. I though it would be much easier to come up to speed given its ‘no-code’ approach.

Hi @Markus_Malessa,

To share my experience:

I have one test sample CUSTOM CLOUD SQL database connected since last month with AppSheet, made a simple apps and it is still connected until today and I have just test it after reading your post.

I was wondering if your issue related is there is additional column to the table, where in AppSheet we need to “Regenerate Structure”.

I was trying to replicate your issue by connecting AppSheet with the DEFAULT CLOUD SQL database, however connection could not be established. It seems something is blocking AppSheet to connect a Default cloud SQL of AppMaker. I don’t know if this is normal or not, I have not connect any of default cloud sql to AppSheet before.

I honor you with your AppMaker knowledge and I was thrilled to see your post here and I hope I could assist you more.

Hi @Heru,

I appreciate the input. I do in fact still run the old of the default database, so in that sense I am actually having ‘Warnings’ under my column tab indicating that my columns are auto increment and that it could cause data loss. I did not think this would cause an IP address error, but I suppose it wouldn’t hurt to correct this. Could you tell me how you went about ‘Regenerating Structure’ in AppSheet?

@Markus_Malessa, to me there will be something going on with the default database with AppMaker shutdown and it is the reason why until now I have not connect it to AppSheet nor planning to.
With my limitation knowledge in AppSheet, I found that the “best way now” is to download the AppMaker data to google sheet and work from there. It is easier to copy the apps to Cloud SQL later when it is ready.

For Regenerating Structure, you may found it here:

Than do:
image

1 Like