Code that used to work no longer working

Hello AppSheet Support,

The below code worked for a long time on my app. Now, when I test it, it no longer works. Why is this?

Thanks!
Tiffany

lookup(
lookup(
lookup([_THISROW],
“clipboard”,
“Key”,
“Customer”),
“routes”,
“key”,
“Driver”
),
“UsersV1”,
“Name”,
“ID”)

Because your data has changed?

The data actually looks the same. All the columns are there.

1 Like

I think you’ll just need to troubleshoot each sub-expression independently to find where the breakdown is. I would suspect that one or more of the three LOOKUP() expressions is returning a blank value, which then causes a cascading failure.

To test, I’d go to the same table that has the current expression, add a new virtual column, edit its App formula expression, then use the Test feature of Expression Builder to try each sub-expression and confirm you get the results you expect. After testing is complete, you can delete the virtual column.

3 Likes

Hi Steve,

Thanks so much for your suggestion! I used the Test function in the expression builder and as it turns out, the expression actually is working like it’s supposed to. But for some reason, the Notification scheme won’t work even though the expression is working.

I brought this up in another post, but basically the audit log details say that there is no user to send the notification to even though the expression is yielding email addresses. Do you know why this might be?

Thank you!
Tiffany

Please post a screenshot of the results of a Test from Expression Assistant showing the results of the complete (three-deep) LOOKUP() expression.

1 Like

Hmmm… Okay, so let’s look at the notification setup. Please post a screenshot of the notification configuration in the workflow.

Might not want to trust the test expression view. I’d go see those values in the app itself displayed as a virtual column to make sure they are there.

Have you tried Test from here?
image