Column Error when Referencing (REF) data from other table in the spreadsheet

Hello Everyone,

Currently my deployed App was working well but after trying to use it got some errors that I can´t understand.

The error fixes when I change the column definition from Ref to Text.

Thank you if somebody can help me Out!

If you haven’t already, please familiarize yourself with this:

Looks like until now, read only tables can have Row number as a key while being ‘ref’ in another table.

That’s changing now it seems. Need to have unique identifiers for read only tables as well.

1 Like

Guys, This seems due a update? @Steve I was using the RowNumber as KEY. And I was Familiariezed with the documents. Now just changing the Key Column the problem solved.

Hi all,

Since some users apps are breaking as a result of this error, we are planning to undo this change in tomorrow’s deployment.

I had originally submitted the change that shows this error, which comes from using the _RowNumber column as the key in your table, with good intentions. We display this error, because if you use _RowNumber as the key, and multiple users insert or delete entries concurrently, data loss can occur. Updates may apply to the wrong record or could fail entirely on some data sources.

However, it has become apparent that this error is too aggressive. For example, the error shouldn’t display for read-only tables. So, that is why I am undoing the change and need to revise my plan with a more responsible solution.

3 Likes

@natalie thanks for your clarification. Hope it can be solved.

Regards!

I agree with this change being implemented because it guides people to properly structuring their apps but even without the over aggressiveness some notification that we would be required to remove/update any table that uses row number as the key would have been a nice heads up. Even if we know we shouldn’t use row number sometimes you just don’t remember to change it.

1 Like