Comma on numbers during entry

Hi, we work with fairly large numbers with quite a few trailing zeros. During data entry we cannot tell whether we have entered the correct amount until we have saved or moved to the next section. Is there a “trick” or way to show commas in numbers BEFORE committing them? I have the comma seperator option turned ON in the settings.

Hi @Jethro
I believe I couldn’t get your issue well enough here. Can you explain a bit more clearly? What do you mean by “…comma seperator option turned ON…”?

Hi LeventK,

This is the option as seen in the image (Show thousands separator):

Even with this turned on, it is only applied after I have saved the record. This means that my users have no clue whether they have typed in one million (1000000) or ten million (10000000) as they are working at a high pace.

I’m afraid it will format the number only when you have saved the value. On workaround is to add an additional show column that would show the chosen value as a text.

1 Like

I see what you mean. During user entry, they cannot see the comma separator. You might want to add this as a Feature Request as it would be logical for the column to respect the column format setting when display the entry. Would have to be processed on the client side, but might be possible.

There can be a work around… but I am not sure if you want to do it.
1st: Create a virtual comlumn, mirror the value of such column. i.e: Num_Seperator = [Amount ]
2nd: Using Slice, to move Num_Seperator position to right below Amount column (for convenient reference).
3rd: (Optional) Hide Num_Seperator column in detail or list view.
That’s it.
p/s: The only problem is the Num_Seperator column only update value after you move to next field to enter value

1 Like

Thank you. This is good enough for me!

1 Like