Concatenate date change to number after syncing

The concatenate date (Friday, 3 Apr 2020) change to number after syncing.

Before syncing
image

After syncing
image

Formula:
Concatenate(Switch(Weekday([REPORT ID]),1,“Sunday”,2,“Monday”,3,“Tuesday”,4,“Wednesday”,5,“Thursday”,6,“Friday”,“Saturday”),”, ” ,Day([REPORT ID]),” ” ,Switch(MONTH([REPORT ID]), 1, “Jan”, 2, “Feb”, 3, “Mar”, 4, “Apr”, 5, “May”, 6, “Jun”, 7, “Jul”, 8, “Aug”, 9, “Sep”, 10, “Oct”, 11, “Nov”, “Dec”),” ”,year([REPORT ID]))

In edit mode, the date is ok.

Is this a bug in Appsheet?

1 Like

Your column type is probably set as “Automatic” or “Number”. Please change it’s type to “Date” from the spreadsheet.

2 Likes

Hi @justin
Does this help

1 Like

Sorry guys, unfortunately, both methods don’t work for me. I tried but it still changed to number. spreadsheet is showing correctly.

Can you please try

TEXT([REPORT ID], " DDDD, DD MMM YYYY") as expression for the Day column?

Edit: However this works only for the virtual column. Real columns seem to convert it to number as you have mentioned.

Edit 2: In case of real column,please change the back end column type for [Day] to “Plain Text”, if you are using Google sheet or suitably to similar column type “text” with other spreadsheet or database. With this setting of even the real column will show the date in the format you desire.

So even without trying anything else, as I suggested in my post earlier, you may first try simply changing the back end column type to "plain text"

4 Likes

Yeah!, works for me. Thanks!

1 Like