Creating a Bot and when passing to a process I'm getting an error

Hello,

I have an app with 2 tables, Owners and Pets. Each table has a Status column, Status and Pet Status respectively. The Pets table references the Owners table, i.e. each Owner can have one or more pets, and this reference is set to IsPartOf, so that from the Owners form view I see all of the registered pets and if I delete an Owner, the Pets should be deleted as well.

When I update the Pet Status for a particular Pet in the Pets table, I then need to also update the Status for the owner. Instead of trying to do something generic, I’m just trying to get something to work, so…

I setup an Event that triggers when the Pet Status is updated to a particular status “Sent Info”, then I created a Bot that contains a Set that calls a process that sets the status of the Owner to “Sent Info”

See screen shots below. When I run it, I get the following error:

“Error encountered in step with name [Set Owner Status to Sent Info]: Could not find row with key: in table:Owners.”

What am I doing wrong?

I think I fixed it.

In the Step “Set Owner Status to Sent Info” in the Bot, in the Process Inputs I added the Owner ID key as a process input.

Owner ID = [Owner ID]
Status = [Pet Status]

Great, glad to hear you were able to figure it out.

1 Like