CSV file downloading blank when based on a slice

I have slice of a main table that is created using a user defined table so they csan search for different type of outlets int he data. It always downloads a blank csv file though with just column headings.

(I posted this previously and Steve asked me to post a screen shot of my table but I can’t find that original post)

So here it is. thanks Phil

Was this the other post?

I didn’t see any contribution by Steve here so maybe there was another thread it was discussed?

I would like to see the Slice definition and the View from which you are trying to activate the CSV download from.

Hi John,

Below is the slice expression. Also are screenshots of the views. I have a gallery view that give the user 3 options for searching the main table with one being a “Postcode deep search”. That takes them to a view of the user defined table “filterlist” where inputs are made. An action button takes the user to a view of the slice with expression below where outlets int he main table are shown if they have the right values in the correct columns.

AND(

IN( [Outlet Rating], SELECT( Filterlist[Outlet Rating], [User Id] =USEREMAIL() ) ),

IN( [Price List], SELECT( Filterlist[Price Band Name], [User Id] =USEREMAIL() ) ),

IN( [Spare], SELECT( Filterlist[Postcode (letters)], [User Id] =USEREMAIL() ) ),

IN( [Outlet Type], SELECT( Filterlist[Outlet Type], [User Id] =USEREMAIL() ) ))

I wonder if it’s the Dashboard view that’s interfering? Try the download on the view based on the slice OUTSIDE of the dashboard.

I think this is a bug with dashboard views.

I copied the sample app you referred to in the original post. I changed the chart to a table and moved the view to the Menu list. I changed the dashboard to show only the Table view and turned on “Show Overlay buttons” feature. I then added an action to download to CSV shown as overlay.

When I tap the button from the Dashboard view, I get a blank file - not even headers.

When I tap the button from the Table view in the Menu, I get a file with the expected headers and data.

I recommend opening this as a bug. Unfortunately, you’ll need to find an alternative way to perform the CSV download.

2 Likes

Thanks John,

Even a staight menu view with no dashboard of the slice doesn’t produce anything either.

I’ve had a play around and the CONTAINS expression works below - which is a part fix as some of the wrong rows will come up as fragmented parts of values will appear in others rather than exact matches.

I’m wondering if SPLIT(LIST might help?

AND(

CONTAINS( SELECT( Filterlist[Outlet Rating], [User Id] =USEREMAIL() ), [Outlet Rating]),

CONTAINS( SELECT( Filterlist[Price Band Name], [User Id] =USEREMAIL() ) ,[Price List] ),

CONTAINS( SELECT( Filterlist[Postcode (letters)], [User Id] =USEREMAIL() ) ,[Spare] ),

CONTAINS( SELECT( Filterlist[Outlet Type], [User Id] =USEREMAIL() ) ,[Outlet Type] ))

Hmm, if the view is showing data, the CSV download should simply copy and write them to file for download, no other magic involved. At that point, I wouldn’t even think the expression for the Slice would come into play - but I don’t know how AppSheet implemented it in the background.

Not sure what you have tried but here is what I would do in these circumstances. I would save to somewhere the current expression used in the Slice. Then I would remove the criteria altogether and retest the download. Slowly build up the expression, testing in between, until it stops working then investigate what you just added to see what could be causing issues.


One other note, CONTAINS(), even though it is working in this case, is not intended to work on Lists. It is meant to test if a substring is contained within another text string.

IN() is actually the correct function to use for your purposes.


If I get some time I may try to create something similar to your example based off of your expression to see if I can re-create a similar issue to what you are seeing.

1 Like

The following seems to work:

I have created 4 new virtual columns (with temp names for the mo) and given each the following app formula

SELECT( Filterlist[Outlet Rating], [User Id] =USEREMAIL() )
SELECT( Filterlist[Price Band Name], [User Id] =USEREMAIL() )
SELECT( Filterlist[Postcode (letters)], [User Id] =USEREMAIL() )
SELECT( Filterlist[Outlet Type], [User Id] =USEREMAIL() )

I then changed the slice formula to the following

AND(
IN( [Outlet Rating], [New Virtual Column] ),
IN( [Price List], [New Virtual Column 1] ),
IN( [Spare], [New Virtual Column 2] ),
IN( [Outlet Type], [New Virtual Column 3] ))

The expression has been broken up using virtual columns which seems to have solved it.

Thanks

Phil

3 Likes

Awesome! So the CSV download is working now?

Yes,

Surpised I got that working so easily

Cheers

1 Like