CSVs in cell without proper spacing of ","

Hi,

I have a VC that creates a list if values (postcode districts). I have an action button that saves that list of values to another table in a cell. Currently the list is saved as below with out a space either side of the “,”. As a result the IN() function when searching for values does not work.

Current result

BA1,BA2,BS31,BA3

Desired resuilt

BA1 , BA2 , BS31 , BA3

This is the expression to get the list. Can I change the expression to space the postcodes properly?

SELECT(Full List Table[Spare], ([Real User] = [District User]), TRUE)

Many thanks

Phil

What is the column type of the virtual column?

Hi Steve,

It is a List type.

I have tried this below

SPLIT(SELECT(Full List Table[Spare], ([Real User] = [District User])), " , ")

which works when the expression is tested with the test feature in t he editor but not when “set the values of some columns in this row” action is used.

thanks

phil

1 Like

Please provide screenshots of the expressions that do not work as expected.

screenshots of the expression test from a virtual column called [District User] in table Assign User Details which works.

The expression worked but when I set my column with the action below it just cleared the cells to nothing.

So I put the expression from the VC column into the action instead and that worked in the sense that it didn’t create bank cells but the result was without the comma spacing again.

Thanks

phil

Well, none of that is what I asked for.

SPLIT(SELECT(Full List Table[Spare], ([Real User] = [District User])), " , ")

Not the screenshot I requested.

Would also like to see the IN() expression that didn’t work.

What is the column type of the District column? I’d guess it’s Text or LongText. If so, change to EnumList.

Hi Steve,

Changing the column type to enumlist worked.

Thank you

Phil

1 Like