Current location - Location Services issue wi...

ux
(John Baer) #1

Current location - Location Services issue with Appsheet run in an iOS app.

I need to know what can I do to prevent redundant location services messages.

I am trying to submit an iOS app that wraps a web view to run the Appsheet web app.

The web app uses the Map view and my future intention is to provide ability to calculate time and distance from current location to a work location address.

For this,

I need to ask permission to use Location Services.

I am finding if I do not implement any Location services messaging in the iOS app, no message appears at all - not even from Appsheet.

However,

as soon as I implement the “When in Use Usage Description” property in the iOS app,

there will be TWO Location service request messages displayed:

the normal message from iOS with a custom message

the Appsheet message - “https://www.appsheet.com” Would Like To Use Your Current Location

The redundant message is causing my iOS app submittal to be rejected.

I have done some research and it seems I have no control over whether or not the Appsheet message is displayed.

Secondly, it seems to only be triggered to display when an iOS property has been implemented in the iOS.

Further, it would be nice if I had control and customization over the Appsheet message.

The message displayed is not very professional for a customer facing app.

What can I do to prevent the redundant messages?

(Praveen Seshadri (AppSheet)) #2

Adding @Brian_Sabino and @Adam_Stone_AppSheet.

@John_Baer1, the ideal person to answer this is Brian, but he is out on vacation thru early next week. Just wanted to let you know that there may be a delay in getting you a response.

(John Baer) #3

@praveen

, thanks!

In the meantime,

is there a way to turn off the Map capabilities all together?

I can submit the iOS app without these enabled initially.

I find when I access a detail view from a Deck and there is an address, it automatically is given the Map action.

I am not seeing a way to disable this is the detail view.