Data Change Workflow - Pulling Wrong Column

Hi all -

I have a fairly simple data change workflow that suddenly stopped working correctly today. Any known issues with this?

The action is to add a row of data to another table, and it seems to be erroring out due to pulling the wrong column.

The error log shows “Errors”: “Error: Value ‘Eric’ in field ‘Timestamp’ cannot be converted to type ‘DateTime’.:”,

But the value to set for the Timestamp field is just a datenow value. It is pulling the Owner field value instead (see below).

Any help/thoughts on this would be greatly appreciated!

1 Like

Did you delete any of your columns? Have you tried regenerating it?

Nope, didn’t make any changes to the app. Was working perfectly until today. I did try regenerating but still getting the same error.

Very odd! Please contact support@appsheet.com for help with this. Someone’s going to have to look under the hood for this one, I think. Please let us know what they find!

Also, unrelated, DATETIME(NOW()) is redundant. NOW() produces a DateTime value, so there’s no need to then convert its result using DATETIME().