Data in data source, but not showing in app

A new row of data was entered into our app. The data was recorded in the data source and no error data entry errors where present in the logs, but we are now unable to see the record in our app. We have since entered new rows of data and they all show up in both the data source and app.

Did you add that record with the app or directly into your data source?

1 Like

With the app.

And you don’t see it with the same app?

1 Like

correct

Any chance that two users have used the app at the same time and they both have filled the same key column’s value?

1 Like

I don’t see any key duplicates.

How are you key values chosen?

Key values are generated by initial value = uniqueID().

Are you able to take a printscreen from your data source where we can see that column and record? What are you using as a data source?

1 Like

Data source is Microsoft Excel file that is located on a SharePoint site. We have re-entered the exact same data a 2nd time and it displays correctly. The first entry is in the data source, but still not displaying in the app. Column A is the Claim Number which is the key for the Claim table. Row is highlighted.

Have you checked that you don’t have exact same value twice in column A?

Yes. I do not.

Then the reason should be in the app. Do you have any slice or security filter that would filter that row away?

1 Like

Yes. We use security filters. But, we re-entered the same data and it shows the second time in the app, but not the first. Doesn’t make sense.

Is it okay if I check your app directly?

Yes

For that, I would need to know your app name and account ID number. Would you please go to My Account > Settings and check the box next to “Allow AppSheet staff to access all of my apps…” and click Save? That will allow us to take a look at the app. Thanks

Thanks. Can you see the info you need in the print screen below. The app is named Gemstone.

Have you tried to remove the security filter?