Date initial value set to 01/01/1970

So I got a specific column that contains a computed value based on a relative input date on another column. But even I have not inputted yet a date in the related column, the computed value on the other column already showed a date with the year 1970. The initial value of that column contains no expression.

Please check that your column type is set correctly in your datasource.

2 Likes

Yes I checked already the properties of each column. Its just that the column with automatic formula returns a certain date (01/01/1970) when the related column is blank.

Is my assumption correct?
#1 - You have one table
#2 - That table contains column A and B.
#3 - Both these columns are set as Date
#4 - Column A is just for the input and no formulas are used
#5 - Column B has an app formula or initial value and it’s calculating the date from Column A
#6 - Before you have added anything in Column A, Column B shows a date 01/01/1970

2 Likes

yes @Aleksi that is right. because the auto compute formula I put in Column B is “Column A + 30”, even if I still don’t enter any value in Column A, the Column B returned a value of 01/31/1970.

So my assumption is that, it must be in the calendar settings or whatsoever.

Your “auto compute formula” must produce no result if [Column A] is blank.

yes @Steve that’s what I wanted also. but I still can’t figure out why it’s showing a value even before I input data in Column A.

Anyways I found a solution for the issue thanks to @Heru for the tip in using the expression IFS and ISNOTBLANK. But still, it’s an additional process for the app to make rather than directly eliminating the original issue.

Here’s the example of my original issue. [1st Month] is showing a value of 01/31/1970 even before I put a value in [Date] or even I don’t put any value in [Date]

1 Like
4 Likes

If Column A has no value, the expression [Column A] + 30 still produces a result. Essentially, the blank Date value defaults to a zero date: the very first date the system can represent. Then 30 can be added to that. The result you’re seeing is the date 30 days after the zero date. So you must use @Heru’s work-around to avoid getting that computed date even when [Column A] is blank.

4 Likes