Date not clearing on IOS devices

My app has some date fields for deadlines. On the Iphone I can’t seem to clear those dates when I need to, it is like if the “clear” button wasn’t even there.
On the computer and Android devices the “clear” button works just fine.

Any light on what I could be doing wrong on my app?

Txs!

Are you able to take a printscreen?

Hello @Aleksi

This is the backend of one of them:

And this is the screenshot of the “clear” I cannot make work on IOS:

Let me know if you need any more images.

Thanks!

So… what happens when you click that “Clear” button? Nothing?

It depends on the device, but on Iphone nothing happens…

Not that this really solves the issue, but I have seen this issue sometimes as well on iPhone. In my case, if I close the Appsheet launcher and the app, and then re-Open and sync, it works…

Thanks @Mike!

It didn’t work for me. Actually it never worked, and I’m talking new devices with the latest OS.

Anyway, one thing that crossed my mind is if it could have anything to do with the fact it is a “mandatory” question and therefore it will let me change the date but not clear it. Having said that, on Android it works! Just yesterday I had someone who has been testing it with me say he couldn’t clear it on the browser either. But with Android devices we have never had any issues!

Hi @Cabelo, it’s a known issue we have with the iOS date picker. Not related to the filed being required.
This shouldn’t happen on browser though, were you able to reproduce it in browser?

I have never had these issues using the browser myself. I asked my colleague again and he mentioned he had very poor internet connection not sure if it was related. Thanks for letting me know it is a normal issue.

Thanks for all the replies!

So @Gil is there any solution/workaround on iOS. We don;'t build the date picker — this is iOS-provided, right?

Any update on this? Still seems to be broken for the time picker on ios. Thanks.

@CGCApp This was fixed a while ago.
Are you still seeing unresponsive clear button in iOS?

Yes. In the attached image the “clear” button does nothing. Note this is time not date.

Thanks @CGCApp, Seems like we fixed it for date fields, but forgot time fields.
Fix is coming in this week.

1 Like