Dear Community: I am trying to make a report ...

(SmartD) #1

Dear Community: I am trying to make a report with images using the Workflow section. The problem is that the images do not fit well in the template and exceed the size of the document (look at the attached image). Does anyone know how to adjust the size of the photo within the spaces of the template? Thanks for your answer.

(Levent KULAÇOĞLU) #2

You can set the image size by applying a formatting rule to your [IMAGE] column. You will notice the section WORKFLOW TEMPLATES IMAGE SIZE

(SmartD) #3

@Levent_KULACOGLU

Thank you very much, I tried it and in effect I could make the photos look smaller. The point is that from there all the photos come out small, although I need some large photos. Is there anything that can be done to control the size of the photos and are sometimes small and other larger within the same report? Thank you very much for your help.

(Levent KULAÇOĞLU) #4

+Soporte SmartD I belive you can do it with the formatting rule. For example, if you want some photos to appear in different size, you have to set separate formatting rule for all sizes. There are a couple of ways to accomplish this. The easiest one is setting a valid condition expression depending on your image name. Ex:

=CONTAINS(“keyboard”,[ImageColumnName])

For sure; this option totally depends on the image name and can be cumbersome.

The best option might be to add a mandatory ENUM field before/after your image column with the options of:

{“Tiny” , “Small” , “Medium” , “Large”}

and create 4 different formatting rules associated with the [IMAGE] column with the condition of (assuming the column header of the ENUM above is ImageSize) :

[ImageSize]=“Tiny” [ImageSize]=“Small” [ImageSize]=“Medium” [ImageSize]=“Large”

and then selecting the respective Workflow Templates image size property as per these.